re = /<img(?:(?!\.gif\b)[^>])+>/
str = '<img src="test.jpg">
<img src="test.gif">
<img src="test.png">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end