package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Z]?[a-z]+`)
var str = `oneTwoThreeFour
lowHigh
WarriorPrincess
SupportSEELE
LaunchFLEIAModule
anotherNASATrip
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}