$re = '/[A-Z]?[a-z]+/';
$str = 'oneTwoThreeFour
lowHigh
WarriorPrincess
SupportSEELE
LaunchFLEIAModule
anotherNASATrip
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);