$re = '/^(?!(?:david|hello|dreamer|John_Doe|socceroos)$|.* )\w.*/mi';
$str = 'david
DaVid
this is a test.
this is a test.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);