re = /^(?!(?:david|hello|dreamer|John_Doe|socceroos)$|.* )\w.*/mi
str = 'david
DaVid
this is a test.
this is a test.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end