# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\{\{Infobox(?:[^{}]|\{\{(?:[^{}]|\{\{[^{}]*\}\})*\}\})*)\[\[ *(?:image|fi(?:le|chier)) *: *([^\|\]]*)[^\]]*\]\]/$1/gmi;t' <<< "{{Infobox xyz
|aaa= Xyz {{foo| {{A NESTED TEMPLATE}} other stuff}}
|bbb= [[Xyz]]
|ccc=[[File:xyz.jpg|thumb|Xyz.]]
|bbb= [[Xyz]]
|ccc=[[Image:xyz.jpg|thumb|Xyz.]]
|ddd= {{lang|en|xyz}}
}}
[[File:abc.jpg|thumb|Abc.]]"