package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^abc\s+xyx\s+\d{2}\s+\d{2}\s+[a-z]\s+[a-z]\s+[a-z]`)
var str = `
\/[a-z]{2}\/prestashop-checkout`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}