package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[img\].*?\[/img\]`)
var str = `[IMG]art_74e7e4f8811380426577.jpeg[/IMG] [IMG]art_74e7e4f8811380426595.jpeg[TITLE]title is always needy[/TITLE][/IMG]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}