re = /\[img\].*?\[\/img\]/i
str = '[IMG]art_74e7e4f8811380426577.jpeg[/IMG] [IMG]art_74e7e4f8811380426595.jpeg[TITLE]title is always needy[/TITLE][/IMG]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end