package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<!--FOO-->(.|\n)*?<!--BAR-->`)
var str = `<!--FOO-->
some text
<!--BAR-->
some other text
<!--FOO-->
some more text
<!--BAR-->`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}