re = /<!--FOO-->(.|\n)*?<!--BAR-->/
str = '<!--FOO-->
some text
<!--BAR-->
some other text
<!--FOO-->
some more text
<!--BAR-->'
# Print the match result
str.match(re) do |match|
puts match.to_s
end