#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\B"\b[^"\n]*\b"\B|\S+"
Local $sString = "sdfj "sdfjjk" & @CRLF & _
"sdfj "sdfjjk" "sdfjjk" & @CRLF & _
""sdfjjk sdfj "sdfjjk" " & @CRLF & _
""ddd"DddD"ddddD""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")