$re = '/\B"\b[^"\n]*\b"\B|\S+/';
$str = 'sdfj "sdfjjk
sdfj "sdfjjk" "sdfjjk
"sdfjjk sdfj "sdfjjk"
"ddd"DddD"ddddD"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);