$re = '/\.(?![^.]*$)/m';
$str = './folder/thisisa.test/file.cxx.h';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;