using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http[^s].*wp-content\/uploads\/";
string input = @"http://example.com/wp-content/uploads/2017/01/image.jpg
https://example.com/wp-content/uploads/2017/01/image2.jpg
http://example.com/wp-content/plugins/example-plugin/images/image.jpg";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}