import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http[^s].*wp-content\\/uploads\\/";
final String string = "http://example.com/wp-content/uploads/2017/01/image.jpg\n"
+ "https://example.com/wp-content/uploads/2017/01/image2.jpg\n"
+ "http://example.com/wp-content/plugins/example-plugin/images/image.jpg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}