package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{(?P<individual>[^{}]+)\}@(?P<domain>\S+)`)
var str = `{kevin.knerr, sam.mcgettrick, mike.grahs}@google.com.au`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}