$re = '~\{(?P<individual>[^{}]+)\}@(?P<domain>\S+)~';
$str = '{kevin.knerr, sam.mcgettrick, mike.grahs}@google.com.au';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);