package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*require\('([^']+)'\);`)
var str = `require('some/path/to/file.less'); \\ asodhaosif;
...
// require('some/path/to/file.less);
require('some/path/to/file.less');
require('some/path/to/file.less');
require('some/path/to/file.less');
require('some/path/to/file.less');`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}