$re = '/^\s*require\(\'([^\']+)\'\);/m';
$str = 'require(\'some/path/to/file.less\'); \\\\ asodhaosif;
...
// require(\'some/path/to/file.less);
require(\'some/path/to/file.less\');
require(\'some/path/to/file.less\');
require(\'some/path/to/file.less\');
require(\'some/path/to/file.less\');';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);