$re = '/(?<=(?<!\d(?=[\.!\?]+\d))[\.!\?])(?![\.!\?]|$)/';
$str = 'one.two!?!!three?4.000.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);