re = /(?<=(?<!\d(?=[\.!\?]+\d))[\.!\?])(?![\.!\?]|$)/
str = 'one.two!?!!three?4.000.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end