package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`HTTP\S+(\s,|$)`)
var str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit, HTTP://unknown/string/in/unknown/place/ , sed do eiusmod tempor incididunt ut labore et dolore magna aliqua
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua, HTTP://unknown/string/in/unknown/place/
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}