re = /HTTP\S+(\s,|$)/
str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit, HTTP://unknown/string/in/unknown/place/ , sed do eiusmod tempor incididunt ut labore et dolore magna aliqua
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua, HTTP://unknown/string/in/unknown/place/
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result