using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*):\/\/([A-Za-z0-9.-]+):([0-9]+)?(.*)$";
string input = @"http://ibin-demo.local:30018/aaa/bbb.ccc
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}