$re = '/^(.*):\/\/([A-Za-z0-9.-]+):([0-9]+)?(.*)$/m';
$str = 'http://ibin-demo.local:30018/aaa/bbb.ccc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);