$re = '~(?:^.*?/\*|\*/.*?/\*|\*/.*)(*SKIP)(*F)|\$var\s*=\s*(?:(?!\*/)[^$;])*~s';
$str = '/* other code $var = value1 */
$var = value2 ;
/*
other code
$var = value3 ;
other code
*/
$var = value4;
$var = value5;
/*
other code
$var = value6;
$var = value7;
$var = value8
*/
$var = value8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);