import re
regex = re.compile(r"(?:^.*?/\*|\*/.*?/\*|\*/.*)(*SKIP)(*F)|\$var\s*=\s*(?:(?!\*/)[^$;])*", flags=re.DOTALL)
test_str = ("/* other code $var = value1 */\n"
"$var = value2 ;\n\n"
"/* \n"
"other code\n"
"$var = value3 ;\n"
"other code\n"
"*/\n\n\n"
"$var = value4;\n"
"$var = value5;\n\n"
"/* \n"
"other code\n"
"$var = value6;\n"
"$var = value7;\n"
"$var = value8\n"
"*/\n\n"
"$var = value8")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")