package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:<.*>)|{(.*)}|([a-z0-9]+)`)
var str = `<hithere> Link `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}