$re = '/(?:<.*>)|{(.*)}|([a-z0-9]+)/i';
$str = '<hithere> Link ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);