#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^hede$(*SKIP)(*F)|^.*"
Local $sString = "Hoho" & @CRLF & _
"Hihi" & @CRLF & _
"Haha" & @CRLF & _
"hede"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)