package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^hede$(*SKIP)(*F)|^.*`)
var str = `Hoho
Hihi
Haha
hede`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}