#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)((^|\s)(right|inner|left)\sjoin\s(.*?)on\s(.*?)(?=(inner|right|where)?))+"
Local $sString = "SELECT a, b, c, de, efe " & @CRLF & _
"FROM aaa a, bbb b " & @CRLF & _
"inner join aaa aa ON aa = aaa " & @CRLF & _
"right join vvv aac On vvv.asdw = adadw AND ccc = aadw " & @CRLF & _
"left join aaaa aa On aaa = sss WHERE a = 'aa'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")