use strict;
my $str = 'SELECT a, b, c, de, efe
FROM aaa a, bbb b
inner join aaa aa ON aa = aaa
right join vvv aac On vvv.asdw = adadw AND ccc = aadw
left join aaaa aa On aaa = sss WHERE a = \'aa\'';
my $regex = qr/((^|\s)(right|inner|left)\sjoin\s(.*?)on\s(.*?)(?=(inner|right|where)?))+/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}