using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_(\d{6})_";
string input = @"ABC_123_Sicherheit AB-12xx bis_AC_13_040816_Schuhe.pdf";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}