const regex = /_(\d{6})_/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('_(\\d{6})_', '')
const str = `ABC_123_Sicherheit AB-12xx bis_AC_13_040816_Schuhe.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}