$re = '/(<a.*>.*<img.*?<\/a>)/';
$str = 'Text Text Text <a href="">Linktext</a> Text Text Text <a href=""><img src=""></a> Test Test Test
Text Text Text <a href="">Linktext</a><a href=""><img src=""></a> Test Test Test
Text Text Text <a href=""><img src=""></a> Test Test Test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);