package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"[^"\\]*(?:\\.[^"\\]*)*(?:"|$)`)
var str = `"this must \" match\\" this text must not be matched "this text must \"be matched as well
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}