$re = '/"[^"\\\\]*(?:\\\\.[^"\\\\]*)*(?:"|$)/m';
$str = '"this must \\" match\\\\" this text must not be matched "this text must \\"be matched as well
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);