$re = '/^[A-Z]{2}[0-9A-Z]{2,32}$/';
$str = 'CZ6508000000192000145999';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);