import re
regex = re.compile(r"^[A-Z]{2}[0-9A-Z]{2,32}$")
test_str = "CZ6508000000192000145999"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")