use strict;
my $str = '# match
/kleinanzeigen/cat_48_5030_ct_0_page_2.html
/hunde/Franz%C3%B6sische+Bulldogge/prp_adrace_ct_0_page_2.html
# no match
/hunde/Mischling/Welpe/R%C3%BCde/euskirchen/prp_adrace_aage_asex_ct_119703.html
/hunde/Kangal/Welpe/H%C3%BCndin/neuhofen/prp_adrace_aage_asex_ct_122319.html
/hunde/Deutsch+Drahthaar/duesseldorf/prp_adrace_ct_119205.html
/hunde/aus+Tierheim/R%C3%BCde/bergneustadt/prp_aprop_asex_ct_119541.html
/hunde/Zwergpudel/Welpe/zuelpich/prp_adrace_aage_ct_119706.html
/hunde/Chihuahua/in+Not/H%C3%BCndin/duisburg/prp_adrace_aprop_asex_ct_119281.html
/hunde/Mischling/aus+Tierheim/Welpe/mommenheim/prp_adrace_aprop_aage_ct_120384.html
/hunde/Sonstige+Hunde/goeppingen/prp_adrace_ct_123004.html
/hunde/Deutscher+Jagdterrier/filderstadt/prp_adrace_ct_122759.html
/hunde/Mischling/in+Not/H%C3%BCndin/reinheim/prp_adrace_aprop_asex_ct_121905.html';
my $regex = qr/^/(hunde|kleinanzeigen)/(?!.*/[a-z]+/).*(prp_[a-z0-9_]+_\d+|cat_48_5030.*)\.html$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}