import re
regex = re.compile(r"^/(hunde|kleinanzeigen)/(?!.*/[a-z]+/).*(prp_[a-z0-9_]+_\d+|cat_48_5030.*)\.html$", flags=re.MULTILINE)
test_str = ("# match\n"
"/kleinanzeigen/cat_48_5030_ct_0_page_2.html\n"
"/hunde/Franz%C3%B6sische+Bulldogge/prp_adrace_ct_0_page_2.html\n\n"
"# no match\n"
"/hunde/Mischling/Welpe/R%C3%BCde/euskirchen/prp_adrace_aage_asex_ct_119703.html\n"
"/hunde/Kangal/Welpe/H%C3%BCndin/neuhofen/prp_adrace_aage_asex_ct_122319.html\n"
"/hunde/Deutsch+Drahthaar/duesseldorf/prp_adrace_ct_119205.html\n"
"/hunde/aus+Tierheim/R%C3%BCde/bergneustadt/prp_aprop_asex_ct_119541.html\n"
"/hunde/Zwergpudel/Welpe/zuelpich/prp_adrace_aage_ct_119706.html\n"
"/hunde/Chihuahua/in+Not/H%C3%BCndin/duisburg/prp_adrace_aprop_asex_ct_119281.html\n"
"/hunde/Mischling/aus+Tierheim/Welpe/mommenheim/prp_adrace_aprop_aage_ct_120384.html\n"
"/hunde/Sonstige+Hunde/goeppingen/prp_adrace_ct_123004.html\n"
"/hunde/Deutscher+Jagdterrier/filderstadt/prp_adrace_ct_122759.html\n"
"/hunde/Mischling/in+Not/H%C3%BCndin/reinheim/prp_adrace_aprop_asex_ct_121905.html")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")