$re = '/(?<!subdomain\.)example\.com/';
$str = 'Here is subdomain.example.com but it doesn\'t match.
Here is example.com which does.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);