re = /(?<!subdomain\.)example\.com/
str = 'Here is subdomain.example.com but it doesn\'t match.
Here is example.com which does.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end