import re
regex = re.compile(r"{.+}")
test_str = ("Competing Titles {#competing-titles .unnumbered}\n"
"================\n\n"
"Why Does He Do That?: Inside the Minds of Angry and Controlling Men {#why-does-he-do-that-inside-the-minds-of-angry-and-controlling-men .unnumbered}")
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)