#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[A-Z](?=.?\d)[A-Z0-9 ]{0,8}$"
Local $sString = "B1 8PT" & @CRLF & _
"SW12 TQ1" & @CRLF & _
"B12 TYP" & @CRLF & _
"A1AAAAAAA" & @CRLF & _
"AA1AAAAAA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")