$re = '/^[A-Z](?=.?\d)[A-Z0-9 ]{0,8}$/mi';
$str = 'B1 8PT
SW12 TQ1
B12 TYP
A1AAAAAAA
AA1AAAAAA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);