$re = '/^\d{1,3}(?:,\d{3})*(\.\d{1,2})?$/';
$str = '12,125.25';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);