#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=.*[+-]\d+\.\d+).*([+-]\d+\.\d+).*|(.*)"
Local $sString = "Stephane Robert (+1.5 Sets)" & @CRLF & _
"Stephane Robert (-1.5 Sets)" & @CRLF & _
"Philipp Kohlschreiber" & @CRLF & _
"Philipp Kohlschreiber (-1.5 Sets)" & @CRLF & _
"Philipp Kohlschreiber (+1.5 Sets)" & @CRLF & _
"Player Names (n)" & @CRLF & _
"Another Player-Player"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)